Cannot set the LOCALE IDENTIFIER of the data source

Discussion in 'microsoft.public.sqlserver.olap' started by Elyo Ravuna, Apr 21, 2009.

  1. Elyo Ravuna

    Elyo Ravuna Guest

    In order to use the "translations" feature of Sql Server Analysis Services
    2008 we need to set the locale identifier of the OLEDB connection string.
    However, it doesn't seem to be possible in Excel 2007.

    Here are the steps to reproduce the problem.

    1- Open Excel 2007
    2- Data > From other sources > From Analysis Services
    3- Select a server and a database (it doesn't matter which), click next,
    click finish
    4- Click properties, clear the "retrieve data and errors in the Office
    display language" checkbox, go to the definition tab, add "Locale
    Identifier=1055" to the end of the connection string.
    5- Click ok twice.
    7- You will see that the locale identifier is not taken into consideration.
    8- Click Data > Properties, go to the definition tab, you will see that the
    "locale identifier" you have just written is lost, it is missing from the
    connection string.

    How can we set the "locale identifier" of an analysis services connection
    string in Excel 2007?

    Best regards.
    Elyo Ravuna
    Avnet Technology Solutions - Turkey
     
    Elyo Ravuna, Apr 21, 2009
    #1
    1. Advertisements

  2. Hello Elyo ,

    Thank you posting!

    This is a quick note to let you know that I am performing research on this
    issue and will get back to you as soon as possible. I appreciate your
    patience.


    Best regards,
    Charles Wang

    Microsoft Online Community Support
    Get Secure! - www.microsoft.com/security
    ====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
    ====================================================
     
    Charles Wang [MSFT], Apr 21, 2009
    #2
    1. Advertisements

  3. Hi Elyo,
    To help isolate this issue to see if this is an issue in the OLE DB
    connection in Excel, could you please first check what the result is if you
    change the current system locale to Turkis (Turkey) in regional and
    language settings in Control Panel?

    Also may you send me (changliw_at_microsoft_dot_com) a screenshot of the
    current result in your Excel 2007 so that I can better understand this
    issue?

    Best regards,
    Charles Wang

    Microsoft Online Community Support
    Get Secure! - www.microsoft.com/security
    ====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
    ====================================================
     
    Charles Wang [MSFT], Apr 22, 2009
    #3
  4. Hi,
    Our lab helped me build a test environment for this issue, however since
    Turkish language is not under the support umbrella of our English based
    support services, our local lab does not have Turkish Office 2007.
    Considering this situation, I designed two tests for my environment, one
    test for translation to Chinese, the other one for translation to Turkish
    with setting "locale idntifier=1055" to the connection string. Here are the
    detailed steps:
    Test Procedure
    ==============
    Test 1 - Test Translation for Chinese
    1. I created three translations for my test cube based on Adventureworks DW
    database, Turkish, French and Chinese.
    2. Deploy and process the cube;
    3. Install Office 2007 with the English AND Chinese languages (since we do
    not have Turkish language Office in our local lab);
    4. Set the primary language in Office Language Settings to Chinese;
    5. Open Excel, create a new connection to the SSAS cube, after finished the
    connection, in the Pivot Table Field List, the Measures and Dimensions
    names were displayed in Chinese;

    Test 2 - Test Translation for Turkish
    Since I did not have Turkish Office installed, there was no Turkish
    language for me to select in the list "Display Microsoft Office menus and
    dialog boxes in" in Microsoft Office Language Settings 2007; then I thought
    in a different way:
    1. Open Excel 2007, click the Data tab, click Connections;
    2. Select the existing connection that I used before and click Properties;
    3. On the Connection Properties window, uncheck "Retrieve data and errors
    in the Office display language when available" on the Usage pane; then
    switch to the Definition pane, add "locale identifier=1055" to the
    connection string, and click OK;
    4. Then the display language for the measures names was Turkish.

    Conclusion
    ==========
    Since our local lab did not have Office 2007 Turkish version, I could not
    perform a dedicated test to verify if this issue was Turkish specific
    issue. From my test, it is most likely that this issue was an Excel
    specific issue not related to SSAS. As a possible workaround, I recommend
    that you try my method in Test 2.

    However according to your latest response, it looked that the method 2 did
    not work at your side. Considering the environment specific of this issue
    and we could not reproduce your issue at our side, I recommend that you
    contact your regional Microsoft Customer Support Services (CSS) via
    telephone so that a dedicated Support Professional can assist you in a more
    efficient manner. Please be advised that contacting phone support will be a
    charged call.

    To obtain the phone numbers for specific technology request please take a
    look at the web site listed below.
    http://support.microsoft.com/default.aspx?scid=fh;EN-US;PHONENUMBERS

    If you are outside the US please see http://support.microsoft.com for
    regional support phone numbers.

    If you would like to perform some self-troubleshooting, you may take the
    following suggestiosn as a reference:
    1. Ensure that the Turkish lanaguage has been installed on your Windows.
    You can go to Regional Settings from Control Panel to check it;
    2. Check if you can reproduce this issue on your other client computer by
    specifying "locale identifier=1055" in your connection string and
    unchecking the "Retrieve data and errors in the Office display language
    when available" on the Usage pane;
    3. To help isolate if this issue was related to your Turkish Office 2007,
    you may check if this issue happens on an Excel 2007 English version, but
    please make sure that the Turkish language has been installed on your
    Windows.

    Thank you for your understanding on this. If you have any other questions
    or concerns, please do not hesitate to let me know.

    Best regards,
    Charles Wang
    Microsoft Online Community Support
    =========================================================
    Delighting our customers is our #1 priority. We welcome your
    comments and suggestions about how we can improve the
    support we provide to you. Please feel free to let my manager
    know what you think of the level of service provided. You can
    send feedback directly to my manager at: .
    =========================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
    =========================================================
     
    Charles Wang [MSFT], May 11, 2009
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.