Clustered SQL2K8 not finding mount points on SAN

Discussion in 'microsoft.public.sqlserver.clustering' started by Robert Hindla, Mar 25, 2009.

  1. Arggh. Clustered W2K8 doesn't want to use mount points on the SAN.
    It will use the mounted volumes as long as I put letters to them in the disk
    management applet, but now I have two reflections of the same volumes in
    the Windows Explorer, the drive lettered volumes and the mounted volumes.
    The cluster works, but only with the drive letters. SQL2K8 can't seem to
    start with a dependency on mount points: I tried taking the letters away
    and SQL2K8 won't start.

    I'm running (or trying to run) SQL2K8 on W2K3 SP2.  I know SQL2005 works
    with Mount Points on W2K3 because I've got it in a three way
    active/active/active cluster.But for W2K8?  No.  Just a disappointment.

    The problem was in set up.  I created the standard 1GB parent drive, and the
    dependent volumes, but when I got to the installation dialog where I could
    assign the temp/log/data devices, I got errors.  I was told, when I
    requested the sql files be created on the mount points, that my suggested
    path was either malformed or not absolute;  if I chose a hard path from the
    root of the parent drive, I was told the drive wasn't in the cluster.

    Here's what I got when I chose a mount point:

    "path \\?\GLOBALROOT\Device\Harddisk5\Partition1\MSSQL.INSTANCE1\MSSQL\DATA\
    is malformed or not absolute.  Error code 0x84B40000."

    When I got chose "e:\mount-point-for-data\mssql.instance1\mssql\data," I was
    told e: wasn't in the cluster.

    A colleague came in and said, "well, assign drive letters to the mounted
    volumes."  So we did that got SQL2K8 to install, but now I'm stuck with the
    drive letters, which we don't want AND the parent drive. When we open the
    explorer now we've got TWO pictures of the same volumes.
    I tried just deleting the drive letters and that didn't work:  SQL couldn't
    start dependent only on the path.
    What a drag.
     
    Robert Hindla, Mar 25, 2009
    #1
    1. Advertisements

  2. Download any CU for SQL 2008.

    Run the CU BEFORE installing SQL. This will leave a "pre-patched" installer
    script for SQL 2008 that should fix your issue.

    Proceed normally with the rest of the installation.
     
    Geoff N. Hiten, Mar 26, 2009
    #2
    1. Advertisements

  3. Yes, I did that. I'm running 10.0.1763 setup support files. Has anyone
    else run into this problem? Do you think there is another fix besides
    10.0.1763 setup files?
     
    Robert Hindla, Mar 26, 2009
    #3
  4. Robert Hindla

    bass_player Guest

    bass_player, Mar 28, 2009
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.