Compact Framework Keeps Deploying

Discussion in 'microsoft.public.sqlserver.ce' started by Mobile Application Developer (MAD), Jul 21, 2009.

  1. ..Net Compact Framework 3.5
    Sql Server Compact 2005
    Visual Studio 2008
    Device: Windows Mobile Processional 6 Classic

    Everytime I start runnin g project in debug it deploys all files and it
    takes long time to startup. Namely, the files that take most time are --
    4>Deploying '%CSIDL_PROGRAM_FILES%\Microsoft SQL Server Compact
    Edition\v3.5\Devices\wce500\ARMV4i\sqlce.ppc.wce5.armv4i.CAB'
    4>Deploying '%CSIDL_PROGRAM_FILES%\Microsoft SQL Server Compact
    Edition\v3.5\Devices\wce500\ARMV4i\sqlce.repl.ppc.wce5.armv4i.CAB'
    4>Deploying '%CSIDL_PROGRAM_FILES%\Microsoft SQL Server Compact
    Edition\v3.5\Devices\wce500\ARMV4i\sqlce.dev.enu.ppc.wce5.armv4i.CAB'

    why does it keep dooing this over and over?

    Thanks
     
    Mobile Application Developer (MAD), Jul 21, 2009
    #1
    1. Advertisements

  2. Mobile Application Developer (MAD)

    Paul Kay Guest

    Go to Project->Properties->Devices and remove tick from 'Deploy the latest
    version of the .Net CF (once you have deployed it once to devices that
    don't include the latest version)

    PK
     
    Paul Kay, Jul 23, 2009
    #2
    1. Advertisements

  3. Yes, I have done this. It is the reason I am in a quandary. There are two
    more projects in solution one c++ and other also .net project. The former one
    I does not use sql server anyways and the latter doesn't either regardless it
    too is set to NOT Deploy latest version of the .Net CF. I am really puzzled
    by this any ideas anyone?
     
    Mobile Application Developer (MAD), Jul 23, 2009
    #3
  4. Mobile Application Developer (MAD)

    Phil H Guest

    Welcome to the wonderful world of CE Embedded development, wher one MS team
    writes stuff to sit on top of another team's stuff, without, seemingly,
    talking to them about how it all works.

    I've just gotten used to the repetetive overkill of file downloading I
    guess, as I'd rather it downloaded twice than forgot !

    The only thing I can think of is that your target is getting power-reset,
    and hence losing its last state ?
    I only normally get all the downloads then, not each time I debug.

    However, with big projects i.e. ones with many dlls, VS still downloads most
    files multiple times !

    phil
     
    Phil H, Jul 24, 2009
    #4
  5. Mobile Application Developer (MAD)

    Paul Kay Guest

    Is there any indication in your Output window, which project is being
    deployed when the other 'unwanted' cabs are deployed.

    Also, you say that you are not 'using' SQL Server in the project(s) BUT do
    you have a reference to SQL Server in the project(s), as a simple reference
    will cause a deployment regardless of whther you actually use the libarry
    ref'd

    Paul K
     
    Paul Kay, Jul 24, 2009
    #5
  6. Well, it's not doing it anymore. I deleted all references and this time made
    sure I chose .net3.5 and mobile 6 dlls. I did not notice that there are
    different versions there. Maybe I had chose 5.0 or 2.0 dll instead of 6.0
    and/or .net 3.5?

    Strange, now it is not happening. Thanks! I'll leave this thread open incase
    it starts to happen again!
     
    Mobile Application Developer (MAD), Jul 28, 2009
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.