Missing "SQL Server" & SQL "Server Agent" Resource after installat

Discussion in 'microsoft.public.sqlserver.clustering' started by JP, Apr 10, 2009.

  1. JP

    JP Guest

    I installed SQL Server 2008 2 node Cluster on a Windows Server 2003
    Enterprise 64-bit Server.

    I opted for "Advanced Cluster Preparation" Option and prepared the two Nodes
    and then performed "Advanced Cluster Completion".

    SQL Server is installed on the cluster; however the "SQL Server" & "SQL
    Server Agent" are missing (doesn't show up under Cluster Resources).

    I tried to create the Resources manually, but received the message stating
    the Resource Type is not found. How do I create a Resource Type manually?

    Any help in resolving this issue will be appreciated. Thanks.
     
    JP, Apr 10, 2009
    #1
    1. Advertisements

  2. JP

    scottdotnot Guest

    For whatever its worth I've got the same issue.

    Originally the agent would not even start on the second node, I found some
    missing registry entries at:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL
    Server\MSSQL10.MSSQLSERVER\SQLServerAgent

    So now it starts manually ok, but I would have expected there to me a
    cluster resource for it.
     
    scottdotnot, Jun 8, 2009
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.