Problem on DTS ported from SQL 2000

Discussion in 'microsoft.public.sqlserver.dts' started by cghersi, Apr 5, 2011.

  1. cghersi

    cghersi Guest

    Hi all,

    I'm trying to port a DTS made in SQL Server 2000 to SQL Server 2005.
    The DTS has a step where I try to read from an .ini file (stored on
    local disk c:\myFolder\myFileIni.ini).
    Under SQL Server Management Studio I'm able to correctly execute the
    package, but when this DTS is executed from SQL Server Agent as part
    of a scheduled job the following error arises:
    "Error = -2147220492 (800403F4) Error string: Could not open
    file for reading. Error source: Dynamic Properties Task"

    I tried to reference such file both with local path c:\myFolder
    \myFileIni.ini and with UNC path (\\MyMachineName\myFolder
    \myFileIni.ini, given that myFolder has been shared with "MyFolder"
    name).
    I also tried to execute the job with a proxied user.

    None of the previous tricks have succeeded.
    Moreover, I'm able to read the file using a T-SQL script executed as
    the proxied user.

    Any hint?

    Thank you very much!

    Bye
    cghersi
     
    cghersi, Apr 5, 2011
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.