Repost: Can't set Locale Identifier through Analysis Services UI

Discussion in 'microsoft.public.sqlserver.olap' started by Jonthan Levine, Jun 8, 2004.

  1. Hi... no response to my previous post, so reposting with my new MSDN email ID

    -----------------------

    I'm connecting an Analysis Services Server running on an Windows 200
    (locale ID 1033) machine to an SQL Server containing Japanese data

    The default connection is in Locale ID 1033, which unfortunatel
    munges the Japanese. So I want to change the Locale ID to 1041

    I've observed the following when trying to do this via the U

    1. Right Click the data sourc
    2. Select Edit..
    3. Select the All ta
    4. Select Locale Identifie
    5. Select Edit Value..
    6. Change the value to 104
    7. OK out of the dialog
    8. Select Edit..
    9. Select the All ta

    OBSERVE: the Locale Identifier is set back to 1033. And the Japanes
    is still munged

    If I go directly into the repository database (in an SQL Serve
    database) and directly change the connection string to include Local
    Identifier=1041, then restart the server, the Japanese appears OK.
    But if I go back to Data Source/Edit.../All, the Locale Identifier i
    still displaying as 1033

    UPDATE: If I set the default charset on the Analysis services box (in Regional Settings) to Japanese, the Locale ID is still 1033, but the Japanese doesn't get munged..

    Is this a bug

    Thanks

    Jonatha
     
    Jonthan Levine, Jun 8, 2004
    #1
    1. Advertisements

  2. Jonthan Levine

    Yuan Shao Guest

    Hi Jonathan,

    As I understand, you want to change the value of the Locale Identifier. You
    may try the following steps.

    a. Start -> Run.
    b. Type "intl.cpl" (without quotation marks) and press enter.
    c. In the Regional Options tab, change the value of the "Select an item to
    match its perferences, or click Customize to choose your own formats" drop
    list box to Japanese. Then press OK button
    d.Restart the Analysis Manager, you may see the value of the Locale
    Identifier is changed to 1041.

    Regards,

    Michael Shao
    Microsoft Online Partner Support
    Get Secure! - www.microsoft.com/security
    This posting is provided "as is" with no warranties and confers no rights.
     
    Yuan Shao, Jun 9, 2004
    #2
    1. Advertisements

  3. Thanks, Michael. That worked.

    It's a little strange that the Locale ID depends on that particular control panel setting, isn't it? And that there's no way to change it in the Analysis services UI.

    Jonathan
     
    Jonathan Levine, Jun 9, 2004
    #3
  4. Jonthan Levine

    Yuan Shao Guest

    Jonathan,

    I am glad to hear that the solution worked. Yes, based on my test, it seems
    the value of locale Identifier of the data source is retreived from the
    locale setting of your system and there is not an easy way to directly
    modify it via Analysis Services UI.

    Regards,

    Michael Shao
    Microsoft Online Partner Support
    Get Secure! - www.microsoft.com/security
    This posting is provided "as is" with no warranties and confers no rights.
     
    Yuan Shao, Jun 9, 2004
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.