SQL2005 x64 Analysis Cluster

Discussion in 'microsoft.public.sqlserver.clustering' started by Sean (UK), Aug 22, 2008.

  1. Sean (UK)

    Sean (UK) Guest

    Hi All,

    I have a strange error with SQL2005 x64 on a HP DL580g5 x64 (Win23k R2 + Sp2).

    I've installed SQL2005 DB and cluster it no problem at all.

    This system is going to be a BI system so I've also tried to install and
    cluster Analysis Services with little success.

    I get a strange error in the app evnt log.

    Category (289) Event ID:0
    The service cannot be started: The following system error occurred: An
    attempt was made to access a socket in a way forbidden by its access
    permissions.

    The cluster account has local admin permissions on all the cluster nodes,
    and I've followed the white paper to configure the cluster.

    I've been clustering SQL for years and SQL 2005 always seems to be work
    straight away.

    I've removed it using the correct cli method and reinstalled, but I seem to
    get the same error....?

    Any ideas? before I try and log a formal fault call with MS..?

    Regards,

    Sean
    Error is
     
    Sean (UK), Aug 22, 2008
    #1
    1. Advertisements

  2. Check that the service account is NOT a domain admin.

    Apply SP2 and it should clean up some of the compatibility issues.
     
    Geoff N. Hiten, Aug 24, 2008
    #2
    1. Advertisements

  3. Sean (UK)

    Sean (UK) Guest

    Hi All,

    I've fixed this by removing the local instance of SSAS on both nodes and
    then reclustering with 1 clustered instance of SSAS then patched to SP2.

    Weird sort of issue or as MS would say Undocumented feature for x64.

    Regards,

    Sean
     
    Sean (UK), Aug 27, 2008
    #3
  4. Local DEFAULT SSAS instance on a cluster node is incompatible with any SSAS
    clustered instance.

    A NAMED instance can be used...

    Pascal
     
    Pascal Deliot, Aug 27, 2008
    #4
  5. IF this is still active....


    I have a 2 node cluster. Each has a default instance of SQL ( database and
    SSAS ) Then there is a clustered, named instance of SQL ( database and SSAS
    ). IF I run the clustered instance on node 1 ( node where the install was
    run from ) it works fine. If I fail the clustered instance to the second
    node it fails if the default instance is running. If the default instance
    is down it works fine. I can than start the default instance and get them
    both to work on the second node. DOES ANYBODY have any input

    url:http://www.ureader.com/msg/11421299.aspx
     
    Michael.varriale, Apr 15, 2009
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.