Urgent... Execution Location=3? - Serverside execution

Discussion in 'microsoft.public.sqlserver.olap' started by Lutz Morrien, Nov 20, 2003.

  1. Lutz Morrien

    Lutz Morrien Guest

    Hi all.
    I know there have been many postings regarding "workload
    shifting from client to server".
    We are using Excel 2000.
    In one of the reports I have changed the connection
    strings of all pivot tables, adding "Execution
    Location=3; Default Isolation Mode=1;". Yet nothing
    changed. The Server still does not get the workload.

    I have done this before on a local system with client and
    server and it worked fine.
    The system i am talking about is AS server with SP3a
    being accessed by Excel2000 running on a metaframe server.

    .... which is why it cannot have all cpu time - the other
    users cannot work during queries (intolerable).


    Before, we have reduced excel's process priority to
    provide enough cpu for other users. This worked ok, but
    made Excel real slow.

    What more can we do?

    Thanks for all hints

    Liutz Morrien
     
    Lutz Morrien, Nov 20, 2003
    #1
    1. Advertisements

  2. Hi,

    We cannot remote (execution location = 3) if either is true:

    · The version of the server is smaller than a certain version
    (basically server much older than the client - much older means: from a
    previous generation of the protocol - to figure out if this is the case see
    if you can remote any query to any cube on this server from that client)

    · If you have rolap dimensions

    · If you use visual mode (see in BOL about MDX Visual Mode) - XL is
    using this for example

    · If you explicitly requested the query to be executed on the
    client (by saying Execution Location=2)

    · If the cube is a session cube

    · if the compare flags of the client/server do not match

    · if the locales are different and you dind't specify in the
    connection string that you want this to be ignored. Think of this as server
    is US (regional setting) and client Dutch (regional setting) you can solve
    this by editing the connection string with LCID like: MSOLAP;Initial
    Catalog=TestMDXClientServer;Locale Identifier=1033;Execution
    Location=3;Default Isolation Mode=1;MDX Compatibility=2

    HTH,
    Bas

    "This posting is provided "AS IS" with no warranties, and confers no
    rights."
     
    Bas Kersten [MSFT], Nov 21, 2003
    #2
    1. Advertisements

  3. Lutz Morrien

    Lutz Morrien Guest

    Bas,
    thank you very much for the information.

    It is hard to find good information on this issue, since
    most systems seem to be able to live with a client using
    100% of cpu.

    Some of the things you mentioned, like rolap or
    explicitly asking for execution location=2 I can rule
    out. I will check on the other issues.

    Thanks again
    Lutz Morrien
     
    Lutz Morrien, Nov 24, 2003
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.